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Summary
The purpose of this document is to describe the deployment of the aerospace application, which is based on the TENT system. It gives an overview of the simulation
environment TENT, a short description of the deployment of provenance in TENT,
and a description of the installation and usage of the TENT demonstrator which has
been deployed as a VMware virtual machine.
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Introduction

This document describes the final deployment of the aerospace application. The
aerospace application is the demonstration application of work package 7, which is
based on the simulation environment TENT [1].
In general, this document aims to be a short introduction of the deployed aerospace
application and its usage to allow an easy demonstration and evaluation of the
aerospace application including provenance data recording and the query tools. This
document has a focus on this demonstration deployment, but the provenance recording
is already part of the general TENT distribution and deployed every current and future
TENT installation.

1.1

Overview

The document gives an overview of the simulation environment TENT, a short description of the deployment of provenance in TENT, and a description of the installation
and usage of the TENT demonstrator which has been deployed as a VMware virtual
machine.

1.2

Audience

The primary audience of this document are:
• Current users of the TENT system, who likes to try out the provenance recording
and query tools without influencing their production environment.
• Computer scientists interested in provenance, who likes to have a demonstration
application which isn’t just a trivial test application.
• Members of the TENT and the provenance development teams, who likes to
have a complete demonstration application for giving presentations and software
demonstrations.

2

The Distributed Simulation Environment TENT

TENT is a software integration and workflow management system that helps to improve the building and management of process chains for complex simulations in distributed environments. All tools of typical simulation workflows can be integrated into
TENT and controlled from the user’s desktop using a graphical user interface (GUI).
The key features of TENT are as follows:
• Flexible configuration, online steering, and visualization of simulations.
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• Utilization of distributed computing resources such as PCs, workstations, clusters, supercomputers, and computational Grids.
• Integration of a project based data management with support for cooperative
working.
Additional features are:
• Visual composition of process chains (workflows).
• Monitoring and steering of running simulations from any computer on the internet.
• Easy integration of existing applications.
• Automatic and efficient data transfer between the stages in the process chain.
2.0.1

Technology

The TENT system has been developed as a component system using several software
technologies, for example:
• Java: All essential parts of TENT are developed in Java to be independent from
different platforms.
• CORBA: TENT uses CORBA for specifying interfaces and for communication
between the different parts of the system. For example, CORBA is used for
controlling the workflow in the distributed environment.
• Globus Toolkit: The Globus Toolkit is used for resource selection, for starting
applications, and for data transfer.
• XML: All file formats specific to TENT (e. g. for configuration files) are defined in XML. Also the data management stores the project information in XML
format on a data server
• Python: TENT uses Python as an integrated scripting language for controlling
workflows and for integration of applications.
• WebDAV: The data management system stores the project information and data
files on a WebDAV-enabled data server.
Fig. 1 shows the general architecture of the TENT system.
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Figure 1: Architecture of the TENT system
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Figure 2: Packages of the TENT system
2.0.2

Packages of the TENT system

The TENT system consists of several software packages, each containing related components and tools. Fig. 2 shows an overview of the existing TENT packages. The base
system covers all basic functionality of the system needed to use it as an integration
environment. This includes components for controlling workflows, factories for starting components and applications in the distributed environment, the name server as
the central information service, and the graphical user interface (GUI).
Support components are additional services for special application scenarios which
are not covered by the basic functionality. Examples of TENT support components are
a data server for storing data files, a monitoring and reporting component, and several
special control components (e. g. for coupled simulations).
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Figure 3: TENT Graphical User Interface.
The components package contains wrappers for integrated applications. Wrappers
are the interface between the actual application and the CORBA side of the TENT system. Currently, there are wrappers for simulation applications such as scientific Computational Fluid Dynamics (CFD) codes (e. g. FLOWer and TRACE), as well as commercial Computational Structural Mechanics (CSM) codes such as MSC/NASTRAN
and ANSYS or visualization tools such as Tecplot or AVS. It also contains wrappers
for all necessary support applications such as pre- and post processing tools (filters).
The Software Development Kit (SDK) is necessary for developing new TENT components.
On top of components are the application systems, which are a proper set of configurations and integrated tools for performing specific tasks.
The most complex single part of TENT is the graphical user interface that allows
the user to build workflows graphically and block oriented (i. e. by interconnection of
the functional blocks), to configure properties of components and applications, to start
and control simulations, and to monitor running applications. The GUI consists of the
following parts (see Fig. 3):
• The component repository for selecting the needed components.
• The project browser for managing the user projects and data on the data server.
• The workflow editor for interconnecting components to workflows.
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• The property editor for setting properties and parameters of components and
applications.
• Some additional panels such as a logger and a scripting console.
The GUI is highly customizable and extensible with Java or Python classes, so that
users can add sophisticated user interfaces for certain applications by creating GUI
plug-ins as needed.

3

Deployment of Provenance in TENT

The current provenance related extensions in TENT have concentrated on the purposes
of the demonstrator. The mapping of the domain to the provenance architecture has
been performed using the PrIMe methodology [2]. The process has been described
and presented in detail in [3, 4]. Provenance actors are identical to the TENT components and the respective interactions are represented by the TENT events that are being
exchanged between the TENT components. Therefore, it is basically these actors and
events that contribute to provenance recording. For the purposes of enabling all possible TENT scenarios for a proper provenance recording additional actors have to be
identified, most of which might be considered “hidden” since they are not obvious
when looking at the respective workflows. Interactions with these actors are not related to TENT events. As TENT event recording has been automated the recording of
these interactions requires an extension and generalization of the way that provenance
related information is collected within TENT.

4

Usage Scenario

The current demonstrator has been built to consecutively run a series of simple two
dimensional computational fluid dynamics (CFD) simulation by means of performing
a parameter variation on one of the input parameters describing the simulation setup.
For each entry from a sequence of three values for the Reynolds number R:
• use the parameter variation component (ParVar) to prepare an input files for the
CFD code,
• pass the input file to the component embedding the CFD code Nast2D,
• run the simulation,
• sent scalar online monitoring data to the GUI for graphical presentation,
• forward the field data obtained as the result of running Nast2D to the visualization component (GNUplot),
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• notify the parameter variation about simulation termination. ParVar then decides
on preparing another input deck or stop the work flow.
See Fig. 4 for a screen shot of the demonstrator work flow and Fig. 5 for the results
of running it.

Figure 4: TENT provenance demonstrator workflow

5

Installation and Usage

A whole provenance enabled simulational engineering environment consists of many
software components that need to interact properly with each other. This setup is
not easily and quickly accomplished. To ease the use for development purposes and
for the purposes of a demonstration system it was decided to create a pre-packaged
system. This system has been implemented using a virtualized operating system based
on VMware. The system image has been set up on top of a slim Debian Linux system.
As the VMware Player is available free of charge to be run on Windows and Linux
systems, this proved to be a suitable way to ship and test run the environment to a
broad audience without imposing any license or license fee issues on anyone.
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Figure 5: TENT provenance demonstrator result visualization

5.1

Requirements and General Information

Information on setup:
• The VMware player is needed to launch the demonstrator image.
• The user conducting the demo is “provenance” with password
“provenance”
• If needed, the user “root” has got password “provenance”
• Install locations:
– eXist: /usr/local/exist
– Provenance Service: /usr/local/ProvenanceService
– Globus container: /usr/local/gt4
– TENT demonstrator: /home/provenance/TENT
– eXo portal: /home/provenance/tmp/exo-tomcat
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• Data directories:
– WebDAV server data: /var/www/webdav
– temporary scratch space for workflow: /home/provenance/worker
• init scripts for starting/stopping services:
– WebDAV server: /etc/init.d/apache2
– eXist server: /etc/init.d/exist
– Globus container: /etc/init.d/globus-4.0

5.2
5.2.1

Step–by–Step Usage
Demonstrator

1. Boot the VMware demonstrator image.
2. Log in as “provenance” (password “provenance”).
3. Start TENT applications:
(a) Start “TENT Naming Service” (double-click on icon). An xterm window opens displaying some logging information.
(b) Start “TENT Factory” (double-click on icon). Another xterm windows
opens.
(c) Start “TENT” (double-click on icon). The TENT GUI is started.
4. In the bottom panel of the TENT GUI Click on “Logger” tab and then
“Global” before performing the next steps in order to watch the progress.
5. Load workflow “ProvenanceDemo”:
(a) Double-click on entry in “Projects” browser on left hand side.
(b) In dialog appearing “Open Simulation” click on “Check-Out”.
6. Activate workflow:
(a) Click on menu “Workflow → Activate All” (or press F9).
(b) Wait for activation (workflow components will all change colour to light
blue).
7. Start workflow:
(a) On very bottom of GUI window click the “play” button in the panel
“action-java”.
(b) As the VMware simulator is quite slow, you may try again if nothing happens (e. g. in the logger).
8. Check progress using monitoring (after workflow has been started):
(a) Click on menu “Tools → Monitoring...”.
(b) In the upcoming tool “TENT Monitoring” double-click on the value
you want to monitor progress on (“Nast2D:delta”, “Nast2D:time”,
or both).
(c) 2D plots will appear and be updated during computation.
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9. After every successful parameter computation the GNUplot component will display the results in a separate window. (GNUplot windows can be closed by
pressing the “Q” key in them.)
10. Close the monitoring plots first, and then the tool “TENT Monitoring”.
11. Close the workflow:
(a) Click on menu “Simulation → Check-In/Close”.
12. Exit the TENT Factory:
(a) Click on menu “Factories → Stop Factory” and select the only
available factory “provdemo”, alternatively .
(b) Type CTRL-C on xterm with “nast2dGnuPlot-factory”.
13. Close TENT:
(a) Click on menu “Project → Exit” or the window’s top right “X” icon.
(b) Confirm exit.
14. Exit the TENT Naming Service:
(a) Type CTRL-C on xterm with “ensd --http --port 7777”.
5.2.2

Query tools

Figure 6: EXo portal login screen
1. At any time during or after a computation the recorded p-assertions can be inspected using the “XQuery Sandbox” on the eXist web tool:
(a) Launch the Firefox browser (use the well known button with the globe icon
in the bottom task bar).
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Figure 7: Provenance stores list

Figure 8: Provenance trace portlet
(b) Chose the “XQuery Sandbox” link in the left hand link bar of the dis-
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Figure 9: Provenance trace portlet success

Figure 10: Provenance process portlet
played web site.
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Figure 11: Provenance relationship portlet
(c) Use your favourite XQuery to retrieve stored results (e. g. “/*”).
2. Subsequent runs of the demonstrator cause additional entries in the provenance
store. In case you want to reset the provenance store:
(a) Open a console window and login as root typing “su -”. The password is
“provenance”.
(b) Change directory to /usr/local/ProvenanceService
(c) Type “ant cleanCollect”
(d) In order to get a listing of other available “ant” targets type “ant -p”
3. For a higher level look at the contents of the provenance store, the eXo portal
has got to be used.
(a) Start the eXo server by opening a new xterm window and type
“exoportal”.
(b) Wait until the server announces the total time spent for start up.
(c) Launch the Firefox browser (use the well known button with the globe icon
in the bottom task bar).
(d) Chose the “eXo Portal” link in the left hand link bar of the displayed web
site.
(e) Login as “exoadmin” with password “exo”. These entries should already be present in the corresponding entry fields. Activate login by clicking on the rightmost right arrow “→” next to the entry fields (see Fig. 6).
(f) A number of labeled boxes appears, each box representing a certain web
application. Select the box termed “ProvenanceStoresList” to ob15
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tain the next screen (see Fig. 7).
(g) There is no need to enter a new store, therefore just proceed.
(h) Activate
the
trace
portlet
by
clicking
on
“GetProvenanceTracePortlet” (see Fig. 8) and press
“Execute Query”.
(i) Please wait ... (the VMWare demonstrator is slow!)
(j) ... until the query has been executed successfully (see Fig. 9).
(k) Run
the
queries
“ProcessPortlet”
and
“RelationshipPortlet” (in that order) to see the provenance
actors and their interactions (see Fig. 10), and the causal relationships
between interactions (see Fig. 11).
After a satisfactory demo, close all windows and shutdown the system using the
provided icon on the desktop.
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